package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(MAINT|(STRY|PRB)-\d+):\s*(?i:\w*(e[a-ce-z]|[a-df-z]d|i(n[a-fh-z]|[a-mo-z]g|e[a-ce-z]|[a-df-z]d)|[a-hj-z]ng|[a-hj-z][a-df-mo-z][a-cefh-z])|\w)\s([a-zA-Z0-9._\-"].*)`)
var str = `MAINT: Refactor something
STRY-1: Add something
STRY-1: popoinfe something
STRY-2: Update something
But should not match the following:
MAINT: Refactored something
STRY-1: Added something
STRY-2: Update something
MAINT: Refactoring something
STRY-3: Adding something
STRY-4: Updating something`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}