const regex = new RegExp('^(MAINT|(STRY|PRB)-\\d+):\\s*(?i:\\w*(e[a-ce-z]|[a-df-z]d|i(n[a-fh-z]|[a-mo-z]g|e[a-ce-z]|[a-df-z]d)|[a-hj-z]ng|[a-hj-z][a-df-mo-z][a-cefh-z])|\\w)\\s([a-zA-Z0-9._\\-"].*)', 'gm')
const str = `MAINT: Refactor something
STRY-1: Add something
STRY-1: popoinfe something
STRY-2: Update something
But should not match the following:
MAINT: Refactored something
STRY-1: Added something
STRY-2: Update something
MAINT: Refactoring something
STRY-3: Adding something
STRY-4: Updating something`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}