const regex = /(?=\d+[ ,\/])([\d,\/\s]{2,})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\d+[ ,\\\/])([\\d,\\\/\\s]{2,})$', 'gm')
const str = `Lorem ipsum 1,2,3
Lorem ipsum 1,2,3,
Lorem ipsum 1, 2, 3
Lorem ipsum 1 2 3
Lorem 12 ipsum 1 2 3
Lorem ipsum 12,13,14
Lorem ipsum 1,12,15
Lorem ipsum 1/12/15
Lorem ipsum
Lorem ipsum 1
Lorem ipsum 2
Lorem ipsum 12
Lorem 12 ipsum 12
Lorem ipsum 1,2,3 and more`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}