use strict;
my $str = 'Lorem ipsum 1,2,3
Lorem ipsum 1,2,3,
Lorem ipsum 1, 2, 3
Lorem ipsum 1 2 3
Lorem 12 ipsum 1 2 3
Lorem ipsum 12,13,14
Lorem ipsum 1,12,15
Lorem ipsum 1/12/15
Lorem ipsum
Lorem ipsum 1
Lorem ipsum 2
Lorem ipsum 12
Lorem 12 ipsum 12
Lorem ipsum 1,2,3 and more';
my $regex = qr/(?=\d+[ ,\/])([\d,\/\s]{2,})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}