# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=\d+[ ,\/])([\d,\/\s]{2,})$"
test_str = ("Lorem ipsum 1,2,3\n"
	"Lorem ipsum 1,2,3,\n"
	"Lorem ipsum 1, 2, 3\n"
	"Lorem ipsum 1 2 3\n"
	"Lorem 12 ipsum 1 2 3\n\n"
	"Lorem ipsum 12,13,14\n\n"
	"Lorem ipsum 1,12,15\n"
	"Lorem ipsum 1/12/15\n\n"
	"Lorem ipsum\n"
	"Lorem ipsum 1\n"
	"Lorem ipsum 2\n"
	"Lorem ipsum 12\n"
	"Lorem 12 ipsum 12\n"
	"Lorem ipsum 1,2,3 and more")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
    
    print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
    
    for groupNum in range(0, len(match.groups())):
        groupNum = groupNum + 1
        
        print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.