using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=0xfe2324).*wzm\s*=\s*(\w+)";
string input = @"0xfe2324 : Wafer = 1351, wzm = 5215, tilt = 3167
It is expressed in this way, but sometimes the location is slightly different, so the a log file takes the wafer value 1351 b log file 5215.
I want to bring only the value of 5215 for wzm.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}