use strict;
my $str = '0xfe2324 : Wafer = 1351, wzm = 5215, tilt = 3167
It is expressed in this way, but sometimes the location is slightly different, so the a log file takes the wafer value 1351 b log file 5215.
I want to bring only the value of 5215 for wzm.';
my $regex = qr/^(?=0xfe2324).*wzm\s*=\s*(\w+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}