import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=0xfe2324).*wzm\\s*=\\s*(\\w+)";
final String string = "0xfe2324 : Wafer = 1351, wzm = 5215, tilt = 3167 \n"
+ "It is expressed in this way, but sometimes the location is slightly different, so the a log file takes the wafer value 1351 b log file 5215.\n"
+ "I want to bring only the value of 5215 for wzm.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}