$re = '/^(?=0xfe2324).*wzm\s*=\s*(\w+)/m';
$str = '0xfe2324 : Wafer = 1351, wzm = 5215, tilt = 3167
It is expressed in this way, but sometimes the location is slightly different, so the a log file takes the wafer value 1351 b log file 5215.
I want to bring only the value of 5215 for wzm.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);