# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=0xfe2324).*wzm\s*=\s*(\w+)"
test_str = ("0xfe2324 : Wafer = 1351, wzm = 5215, tilt = 3167 \n"
"It is expressed in this way, but sometimes the location is slightly different, so the a log file takes the wafer value 1351 b log file 5215.\n"
"I want to bring only the value of 5215 for wzm.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.