import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?!y).+)\\s*([+-/])\\s*((?!.*x)(?=.*y).+)\\s*=.+";
final String string = "x^2 + y^2=1\n"
+ "69/7+ x^2+y^2=1\n"
+ "x^2-y^2/2=1\n"
+ "sinx^2-cosy^2=1\n"
+ "(x^2-1/2(3*5))-cosy^2=1\n"
+ "sinx^2-cosy^2+58=1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}