re = /((?!y).+)\s*([+-\/])\s*((?!.*x)(?=.*y).+)\s*=.+/m
str = 'x^2 + y^2=1
69/7+ x^2+y^2=1
x^2-y^2/2=1
sinx^2-cosy^2=1
(x^2-1/2(3*5))-cosy^2=1
sinx^2-cosy^2+58=1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end