const regex = /((?!y).+)\s*([+-/])\s*((?!.*x)(?=.*y).+)\s*=.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?!y).+)\\s*([+-\/])\\s*((?!.*x)(?=.*y).+)\\s*=.+', 'gm')
const str = `x^2 + y^2=1
69/7+ x^2+y^2=1
x^2-y^2/2=1
sinx^2-cosy^2=1
(x^2-1/2(3*5))-cosy^2=1
sinx^2-cosy^2+58=1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}