#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "h1>(.+?)\s*\((\d*)\)<(?s).+?h2>(.+?)<"
Local $sString = "" & @CRLF & _
" <h1>valami szöveg1 (0000)</h1>" & @CRLF & _
" " & @CRLF & _
" <h2>valami szöveg2</h2>" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")