package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`h1>(.+?)\s*\((\d*)\)<(?s).+?h2>(.+?)<`)
var str = `
<h1>valami szöveg1 (0000)</h1>
<h2>valami szöveg2</h2>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}