import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "h1>(.+?)\\s*\\((\\d*)\\)<(?s).+?h2>(.+?)<";
final String string = "\n"
+ " <h1>valami szöveg1 (0000)</h1>\n"
+ " \n"
+ " <h2>valami szöveg2</h2>\n"
+ " ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}