// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"h1>(.+?)\s*\((\d*)\)<(?s).+?h2>(.+?)<").unwrap();
let string = "
<h1>valami szöveg1 (0000)</h1>
<h2>valami szöveg2</h2>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}