$re = '/name="(.*?)" value="(.*?)"/is';
$str = '<input type="hidden" name="semvalue">
<input type="hidden" value="abc">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);