re = /name="(.*?)" value="(.*?)"/i
str = '<input type="hidden" name="semvalue">
<input type="hidden" value="abc">'
# Print the match result
str.match(re) do |match|
puts match.to_s
end