import re
regex = re.compile(r"name=\"(.*?)\" value=\"(.*?)\"", flags=re.IGNORECASE | re.DOTALL)
test_str = ("<input type=\"hidden\" name=\"semvalue\">\n"
"<input type=\"hidden\" value=\"abc\">")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")