import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sx)User:\\h([^\\n]+)\\n\n"
+ "Login\\-name:\\h([^\\n]+)\\n\n"
+ "(?:CaseSensitive:\\h([^\\n]+)\\n)?\n"
+ "NTSecurity:\\h([^\\n]+)\\n\n"
+ "(?:NO\\n)?\n"
+ "(?:Domain:\\h([^\\n]+)\\n)?\n"
+ "Timeout:\\h([^\\n]+)\\n\n"
+ ".*?\n"
+ "Member:\\h([^\\n]+)\\n";
final String string = "User: AMMINISTRATORE\n"
+ "Login-name: ADM\n"
+ "CaseSensitive: YES\n"
+ "NTSecurity: NO\n"
+ "NO\n"
+ "Timeout: 00:05:00\n"
+ "Member: AMMINISTRATORI\n\n"
+ "User: Test_User\n"
+ "Login-name: Test_User\n"
+ "NTSecurity: YES\n"
+ "Domain: DNEU\n"
+ "Timeout: 00:00:00\n"
+ "Member: OPERATORS\n"
+ "Member: OPERATORS";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}