$re = '/(?sx)User:\h([^\n]+)\n
Login\-name:\h([^\n]+)\n
(?:CaseSensitive:\h([^\n]+)\n)?
NTSecurity:\h([^\n]+)\n
(?:NO\n)?
(?:Domain:\h([^\n]+)\n)?
Timeout:\h([^\n]+)\n
.*?
Member:\h([^\n]+)\n/';
$str = 'User: AMMINISTRATORE
Login-name: ADM
CaseSensitive: YES
NTSecurity: NO
NO
Timeout: 00:05:00
Member: AMMINISTRATORI
User: Test_User
Login-name: Test_User
NTSecurity: YES
Domain: DNEU
Timeout: 00:00:00
Member: OPERATORS
Member: OPERATORS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);