package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(?:(,)\s*)+|(\s)+`)
var str = `first , second ,, third, ,fourth suffix`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}