const regex = /\s*(?:(,)\s*)+|(\s)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(?:(,)\\s*)+|(\\s)+', 'gm')
const str = `first , second ,, third, ,fourth suffix`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);