$re = '/\s*(?:(,)\s*)+|(\s)+/m';
$str = 'first , second ,, third, ,fourth suffix';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;