use strict;
my $str = 'first , second ,, third, ,fourth suffix';
my $regex = qr/\s*(?:(,)\s*)+|(\s)+/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";