re = /\s*(?:(,)\s*)+|(\s)+/m
str = 'first , second ,, third, ,fourth suffix'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result