package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-z\d\.-_-]+)@([a-z\d-]+)([\.])([a-z]{2,6})(\.[a-z]{2,6})?$`)
var str = `super_cool-email.address@must-match-fully.com
super_cool-email.address@must-match-fully.co.uk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}