import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z\\d\\.-_-]+)@([a-z\\d-]+)([\\.])([a-z]{2,6})(\\.[a-z]{2,6})?$";
final String string = "super_cool-email.address@must-match-fully.com\n\n"
+ "super_cool-email.address@must-match-fully.co.uk";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}