const regex = /^([a-z\d\.-_-]+)@([a-z\d-]+)([\.])([a-z]{2,6})(\.[a-z]{2,6})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-z\\d\\.-_-]+)@([a-z\\d-]+)([\\.])([a-z]{2,6})(\\.[a-z]{2,6})?$', 'gm')
const str = `super_cool-email.address@must-match-fully.com
super_cool-email.address@must-match-fully.co.uk`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}