// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-z\d\.-_-]+)@([a-z\d-]+)([\.])([a-z]{2,6})(\.[a-z]{2,6})?$").unwrap();
let string = "super_cool-email.address@must-match-fully.com
super_cool-email.address@must-match-fully.co.uk";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}