#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\n"
Local $sString = "Linkin Park" & @CRLF & _
"Rammstein" & @CRLF & _
"Metallica" & @CRLF & _
"Guns N' Roses"
Local $sSubst = "|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)