$re = '/\n/';
$str = 'Linkin Park
Rammstein
Metallica
Guns N\' Roses';
$subst = "|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;