import re
regex = re.compile(r"\n")
test_str = ("Linkin Park\n"
"Rammstein\n"
"Metallica\n"
"Guns N' Roses")
subst = "|"
result = regex.sub(subst, test_str)
if result:
print(result)