re = /\n/
str = 'Linkin Park
Rammstein
Metallica
Guns N\' Roses'
subst = '|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result