import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:.*\\\\\\\\)?(?<username>.*)";
final String string = "SPLUNK\\\\xander\n"
+ "DOMAIN\\\\foo\n"
+ "WORK\\\\reswob4\n"
+ "username\n"
+ "username\n"
+ "WORK\\\\username";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}