$re = '/(?:.*\\\\\\\\)?(?<username>.*)/m';
$str = 'SPLUNK\\\\xander
DOMAIN\\\\foo
WORK\\\\reswob4
username
username
WORK\\\\username';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);