re = /(?:.*\\\\)?(?<username>.*)/m
str = 'SPLUNK\\\\xander
DOMAIN\\\\foo
WORK\\\\reswob4
username
username
WORK\\\\username'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end