import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(m/\\w+/g)[5]";
final String string = "RA 45Q@6 Hermann Meyer Fall01\n"
+ "LA 4567.8 Katrin Schmitt Fall030\n"
+ "BA 45h12x Josef Mueller Fall040\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}