use strict;
my $str = 'RA 45Q@6 Hermann Meyer Fall01
LA 4567.8 Katrin Schmitt Fall030
BA 45h12x Josef Mueller Fall040
';
my $regex = qr~(m/\w+/g)[5]~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}