#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\p{L}+)(?:_\p{L}+)*_(\p{L})\p{L}*$"
Local $sString = "Thomas_J_Perkins" & @CRLF & _
"" & @CRLF & _
"Jennifer_Scanner" & @CRLF & _
"" & @CRLF & _
"Amanda_K_Loso" & @CRLF & _
"" & @CRLF & _
"Aaron_Cole" & @CRLF & _
"" & @CRLF & _
"Mark_L_Lamb"
Local $sSubst = "\1_\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)