import Foundation
let pattern = #"^(\p{L}+)(?:_\p{L}+)*_(\p{L})\p{L}*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Thomas_J_Perkins
Jennifer_Scanner
Amanda_K_Loso
Aaron_Cole
Mark_L_Lamb
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1_\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)