$re = '/^(\p{L}+)(?:_\p{L}+)*_(\p{L})\p{L}*$/m';
$str = 'Thomas_J_Perkins
Jennifer_Scanner
Amanda_K_Loso
Aaron_Cole
Mark_L_Lamb';
$subst = "\1_\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;