use strict;
my $str = 'Thomas_J_Perkins
Jennifer_Scanner
Amanda_K_Loso
Aaron_Cole
Mark_L_Lamb';
my $regex = qr/^(\p{L}+)(?:_\p{L}+)*_(\p{L})\p{L}*$/mp;
my $subst = '\\1_\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";