package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\p{L}+)(?:_\p{L}+)*_(\p{L})\p{L}*$`)
var str = `Thomas_J_Perkins
Jennifer_Scanner
Amanda_K_Loso
Aaron_Cole
Mark_L_Lamb`
var substitution = "\1_\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}