using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\?[A-Za-z](?:\?[^?\n]*\?|[^?\n])*?\? ";
string input = @"hello ?color red ?name Yuri ? ? to the forum
hello ?name Yuri ? welcome to ?forum Python ? It's awesome!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}