$re = '/\?[A-Za-z](?:\?[^?\n]*\?|[^?\n])*?\? /m';
$str = 'hello ?color red ?name Yuri ? ? to the forum
hello ?name Yuri ? welcome to ?forum Python ? It\'s awesome!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);