// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\?[A-Za-z](?:\?[^?\n]*\?|[^?\n])*?\? ").unwrap();
let string = "hello ?color red ?name Yuri ? ? to the forum
hello ?name Yuri ? welcome to ?forum Python ? It's awesome!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}