package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\?[A-Za-z](?:\?[^?\n]*\?|[^?\n])*?\? `)
var str = `hello ?color red ?name Yuri ? ? to the forum
hello ?name Yuri ? welcome to ?forum Python ? It's awesome!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}