re = /\?[A-Za-z](?:\?[^?\n]*\?|[^?\n])*?\? /m
str = 'hello ?color red ?name Yuri ? ? to the forum
hello ?name Yuri ? welcome to ?forum Python ? It\'s awesome!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end